# Contributor: Drew DeVault <sir@cmpwn.com>
# Maintainer: Drew DeVault <sir@cmpwn.com>
pkgname=py3-aiosmtpd
_pyname=aiosmtpd
pkgver=1.4.2
pkgrel=1
pkgdesc="A reimplementation of the Python stdlib smtpd.py based on asyncio"
url="https://github.com/aio-libs/aiosmtpd"
arch="noarch"
license="Apache-2.0"
depends="py3-atpublic"
makedepends="python3-dev py3-setuptools"
checkdepends="py3-pytest py3-pytest-mock py3-pluggy"
_pypiprefix="${_pyname%${_pyname#?}}"
source="https://files.pythonhosted.org/packages/source/$_pypiprefix/$_pyname/$_pyname-$pkgver.tar.gz"
replaces="py-aiosmtpd"
builddir="$srcdir"/$_pyname-$pkgver
options="!check" # https://gitlab.alpinelinux.org/alpine/aports/-/issues/12503
build() {
python3 setup.py build
}
check() {
pytest-3
}
package() {
python3 setup.py install --prefix=/usr --root="$pkgdir"
}
sha512sums="
b910ae4c00b52f59b9f2199b296a1b76caa7567cbcd2e27c73d4ec894e9b48cd8190090083ce33b87dc924c4394a6425506355951208af65b89a6c1abe371114 aiosmtpd-1.4.2.tar.gz
"