# Maintainer: Drew DeVault <sir@cmpwn.com>
pkgname=py3-stripe
_pyname=stripe
pkgver=2.56.0
pkgrel=0
pkgdesc="An easy whitelist-based HTML-sanitizing tool"
url="https://github.com/stripe/stripe-python"
arch="noarch"
license="MIT"
depends="python3"
_pypiprefix="${_pyname%${_pyname#?}}"
source="https://files.pythonhosted.org/packages/source/$_pypiprefix/$_pyname/$_pyname-$pkgver.tar.gz"
makedepends="py3-setuptools py3-requests"
builddir="$srcdir/$_pyname-$pkgver"
build() {
python3 setup.py build
}
check() {
python3 setup.py check
}
package() {
python3 setup.py install --root="$pkgdir" --optimize=1
}
sha512sums="1f2f08b5425ad48df9afc78f574109604319ccfcdb2fba8ca574008de5dadb349eec84d0e6cf532c57218bc8624af9b256a29ef01facb950a3cfd1168d8c2660 stripe-2.56.0.tar.gz"