# Maintainer: Drew DeVault <sir@cmpwn.com>
pkgname=py3-stripe
_pyname=stripe
pkgver=3.5.0
pkgrel=0
pkgdesc="Python library for the Stripe API"
url="https://github.com/stripe/stripe-python"
arch="noarch"
license="MIT"
depends="python3"
_pypiprefix="${_pyname%${_pyname#?}}"
source="https://files.pythonhosted.org/packages/source/$_pypiprefix/$_pyname/$_pyname-$pkgver.tar.gz"
makedepends="py3-setuptools py3-build py3-installer py3-wheel py3-requests"
checkdepends="py3-pytest"
builddir="$srcdir/$_pyname-$pkgver"
options="!check" # requires network access
build() {
python3 -m build --no-isolation --wheel
}
check() {
python3 -m pytest
}
package() {
python3 -m installer -d"$pkgdir" dist/$_pyname-$pkgver-py2.py3-none-any.whl
}
sha512sums="
67e63f95b489e049d81d9b3929342a8cc2bc3638060d9f278752459d32408bfe8d5f09c4c047a1ed0deedce875b0a84873a3b120f6bb5f30c0668eda5129e4ee stripe-3.5.0.tar.gz
"