# Maintainer: Drew DeVault <sir@cmpwn.com>
pkgname=py3-weasyprint
_pyname=WeasyPrint
pkgver=52.5
pkgrel=2
pkgdesc="cairo-based HTML renderer for python"
url="https://weasyprint.org"
arch="noarch"
license="BSD-3-Clause"
depends="
pango cairo py3-cairocffi py3-cairosvg py3-cssselect2 py3-tinycss2 py3-pyphen
py3-lxml py3-pdfrw
"
makedepends="py3-setuptools"
checkdepends="py3-pytest-runner"
_pypiprefix="${_pyname%${_pyname#?}}"
source="https://files.pythonhosted.org/packages/source/$_pypiprefix/$_pyname/$_pyname-$pkgver.tar.gz"
builddir="$srcdir"/$_pyname-$pkgver
replaces="py-weasyprint" # Backwards compat
provides="py-weasyprint=$pkgver-r$pkgrel" # Backwards compat
prepare() {
sed -i setup.cfg -e 's/options.entry_points/entry_points/g'
}
build() {
python3 setup.py build
}
check() {
python3 setup.py check
}
package() {
python3 setup.py install --prefix=/usr --root="$pkgdir"
}
sha512sums="0ce86db000adef95fabfb335c069ad2a602ed98056219cedde905c550b04b10b0881d72fbdd38a48fae4e263825f5fbd8a70ce13932083afb8930eacc5817fb5 WeasyPrint-52.5.tar.gz"