# Maintainer: Drew DeVault <sir@cmpwn.com>
pkgname=py3-weasyprint
_pyname=WeasyPrint
pkgver=47
pkgrel=1
pkgdesc="cairo-based HTML renderer for python"
url="https://weasyprint.org"
arch="noarch"
license="BSD-3-Clause"
depends="
pango cairo py3-cairocffi py3-cairosvg py3-cssselect2 py3-tinycss2 py3-pyphen
py3-lxml py3-pdfrw
"
makedepends="py3-setuptools"
_pypiprefix="${_pyname%${_pyname#?}}"
source="https://files.pythonhosted.org/packages/source/$_pypiprefix/$_pyname/$_pyname-$pkgver.tar.gz"
builddir="$srcdir"/$_pyname-$pkgver
replaces="py-weasyprint" # Backwards compat
provides="py-weasyprint=$pkgver-r$pkgrel" # Backwards compat
build() {
python3 setup.py build
}
check() {
python3 setup.py check
}
package() {
python3 setup.py install --prefix=/usr --root="$pkgdir"
}
sha512sums="1f840d997d33aebd2a8a4c2dafdfec0dfe13a97beda21438f69e28f6bfca8a6fcfe0496cb5a9fa4307e6807b23e2ba656093fe90e3fb2269a865e56a9a83fe1b WeasyPrint-47.tar.gz"