# Maintainer: Drew DeVault <sir@cmpwn.com>
pkgname=py3-llfuse
_pyname=llfuse
pkgver=1.3.6
pkgrel=0
pkgdesc="Python bindings for the low-level FUSE API"
url="https://pypi.org/project/llfuse/"
arch="all"
license="LGPL-3.0"
depends="python3 python3-dev cython fuse-dev"
checkdepends="py3-pytest"
makedepends="py3-setuptools"
_pypiprefix="${_pyname%${_pyname#?}}"
source="https://files.pythonhosted.org/packages/source/$_pypiprefix/$_pyname/$_pyname-$pkgver.tar.bz2"
builddir="$srcdir/$_pyname-$pkgver"
build() {
python3 setup.py build
}
check() {
pyver=$(python3 --version | cut -d' ' -f2 | cut -d. -f1-2)
export PYTHONPATH=build/lib.linux-$(uname -m)-$pyver/
pytest-3
}
package() {
python3 setup.py install --root="$pkgdir" --optimize=1
}
sha512sums="d67e39daf65c92ebb5bf69abb0c5dc3a88460228b5ec5ee762a11fc909369562411297e8ff9f512ee1ef539d8abec765924be581703fb7e99963c6512cb1f0bd llfuse-1.3.6.tar.bz2"