# Maintainer: Drew DeVault <sir@cmpwn.com>
pkgname=py3-weasyprint
_pyname=WeasyPrint
pkgver=52.1
pkgrel=0
pkgdesc="cairo-based HTML renderer for python"
url="https://weasyprint.org"
arch="noarch"
license="BSD-3-Clause"
depends="
pango cairo py3-cairocffi py3-cairosvg py3-cssselect2 py3-tinycss2 py3-pyphen
py3-lxml py3-pdfrw
"
makedepends="py3-setuptools"
_pypiprefix="${_pyname%${_pyname#?}}"
source="https://files.pythonhosted.org/packages/source/$_pypiprefix/$_pyname/$_pyname-$pkgver.tar.gz"
builddir="$srcdir"/$_pyname-$pkgver
replaces="py-weasyprint" # Backwards compat
provides="py-weasyprint=$pkgver-r$pkgrel" # Backwards compat
build() {
python3 setup.py build
}
check() {
python3 setup.py check
}
package() {
python3 setup.py install --prefix=/usr --root="$pkgdir"
}
sha512sums="3c2a4ade455ee453f9618bed85390ce664ceb609b2a3af0e1befa0038cbd36b32a314287118cdb07abb454f5f09f1eda1ca9b42266b4b627b714306dd60e97e3 WeasyPrint-52.1.tar.gz"