# Contributor: Drew DeVault <sir@cmpwn.com>
# Maintainer: Drew DeVault <sir@cmpwn.com>
pkgname=py3-contextlib2
_pyname=contextlib2
pkgver=0.6.0
pkgrel=0
pkgdesc="Backports and enhancements for the contextlib module"
url="https://pypi.org/project/contextlib2/"
arch="noarch"
license="MIT"
depends="py3-more-itertools"
makedepends="py3-setuptools py3-setuptools_scm"
_pypiprefix="${_pyname%${_pyname#?}}"
source="https://files.pythonhosted.org/packages/source/$_pypiprefix/$_pyname/$_pyname-$pkgver.tar.gz"
builddir="$srcdir"/$_pyname-$pkgver
build() {
python3 setup.py build
}
check() {
python3 setup.py test
}
package() {
python3 setup.py install --prefix=/usr --root="$pkgdir"
}
sha512sums="01901ac226c7fca40add00e95cedb2535a802e0114a53ae1315c6dfee20744dbafa7d9619986ad76345ad9b9aa3e364ac01d23f51b5eb70dd2febd5af1f1fc56 contextlib2-0.6.0.tar.gz"