# Maintainer: Drew DeVault <sir@cmpwn.com>
pkgname=py3-html5lib
_pyname=html5lib
pkgver=1.0.1
pkgrel=1
pkgdesc="A Python HTML parser/tokenizer based on the WHATWG HTML5 spec"
url="https://github.com/html5lib"
arch="noarch"
license="MIT"
depends="py3-six py3-webencodings"
makedepends="py3-setuptools"
_pypiprefix="${_pyname%${_pyname#?}}"
source="https://files.pythonhosted.org/packages/source/$_pypiprefix/$_pyname/$_pyname-$pkgver.tar.gz"
builddir="$srcdir/$_pyname-$pkgver"
build() {
python3 setup.py build
}
check() {
python3 setup.py check
}
package() {
python3 setup.py install --root="$pkgdir" --optimize=1
}
sha512sums="35939b4450893864da04e735ee5e0addacf1dd34bae6a6909c76572abf6bfded446a78a713dfde91c1485ba45867d7abeb6a45cf0545c16ea968707be7de5dd2 html5lib-1.0.1.tar.gz"