# Maintainer: Drew DeVault <sir@cmpwn.com>
pkgname=py3-pytest-flake8
_pyname=pytest-flake8
pkgver=1.0.6
pkgrel=0
pkgdesc="pytest plugin for efficiently checking PEP8 compliance"
url="https://pypi.org/project/pytest-flake8/"
arch="noarch"
license="3-Clause-BSD"
depends="py3-pytest py3-flake8"
makedepends="py3-setuptools"
_pypiprefix="${_pyname%${_pyname#?}}"
source="https://files.pythonhosted.org/packages/source/$_pypiprefix/$_pyname/$_pyname-$pkgver.tar.gz"
builddir="$srcdir/$_pyname-$pkgver"
build() {
python3 setup.py build
}
check() {
python3 setup.py test
}
package() {
python3 setup.py install --prefix=/usr --root="$pkgdir"
}
sha512sums="e1c76f4a170ca6fd94e27cf296b366a2a02f09e4216ded74b4724d8d19f50364caf245e4385b1cb644ead06b890df22400637773716190f673d3de254f5868f5 pytest-flake8-1.0.6.tar.gz"