# Maintainer: Drew DeVault <sir@cmpwn.com>
pkgname=sr.ht-nginx
pkgver=0_git20210830
_commit=dcfe4221f8eaf254add1035d5735a24f3fe0224b
pkgrel=3
pkgdesc="sr.ht common nginx files"
url="https://git.sr.ht/~sircmpwn/sr.ht-nginx"
arch="noarch"
license="AGPLv3"
depends="nginx"
replaces="nginx" # To overwrite nginx.conf
source="
https://git.sr.ht/~sircmpwn/sr.ht-nginx/archive/$_commit.tar.gz
"
builddir="$srcdir/$pkgname-$_commit"
options="$options !check"
build() {
true # no-op
}
package() {
mkdir -p "$pkgdir"/etc/nginx
install -Dm644 graphql.conf "$pkgdir"/etc/nginx/graphql.conf
install -Dm644 nginx.conf "$pkgdir"/etc/nginx/nginx.conf
install -Dm644 port443.conf "$pkgdir"/etc/nginx/port443.conf
install -Dm644 port80.conf "$pkgdir"/etc/nginx/port80.conf
install -Dm644 sourcehut.conf "$pkgdir"/etc/nginx/sourcehut.conf
install -Dm644 web.conf "$pkgdir"/etc/nginx/web.conf
mkdir -p "$pkgdir"/var/www
install -Dm644 robots.txt "$pkgdir"/var/www/robots.txt
}
sha512sums="
a495bbd65fde10ccce6f7875116e7283ce71f31350ddd5e35732eadf17af159a9bf93664777997d178d793d75ae7b5e3e492a9e8cc99f7f58d39199be92ccc5f dcfe4221f8eaf254add1035d5735a24f3fe0224b.tar.gz
"