# Maintainer: Drew DeVault <sir@cmpwn.com>
pkgname=py3-iso3166
_pyname=iso3166
pkgver=2.0.2
pkgrel=0
pkgdesc="Self-contained ISO 3166-1 country definitions for Python"
url="https://github.com/deactivated/python-iso3166"
arch="noarch"
license="MIT"
depends="python3"
makedepends="py3-setuptools"
checkdepends="py3-pytest"
_pypiprefix="${_pyname%${_pyname#?}}"
source="https://files.pythonhosted.org/packages/source/$_pypiprefix/$_pyname/$_pyname-$pkgver.tar.gz"
builddir="$srcdir/$_pyname-$pkgver"
build() {
python3 setup.py build
}
check() {
PYTHONPATH=. pytest-3
}
package() {
python3 setup.py install --root="$pkgdir" --optimize=1
}
sha512sums="
eb5c27c69e29c4312f3a5146206032aae49ee489d9a5987fce1fb66bae9d93ec252bf7fd1119403a278f66adaa5ce1c77fe8d3a1622c46ae4a291d73e5c9fb21 iso3166-2.0.2.tar.gz
"