# Maintainer: Drew DeVault <sir@cmpwn.com>
pkgname=py3-stripe
_pyname=stripe
pkgver=3.2.0
pkgrel=0
pkgdesc="Python library for the Stripe API"
url="https://github.com/stripe/stripe-python"
arch="noarch"
license="MIT"
depends="python3"
_pypiprefix="${_pyname%${_pyname#?}}"
source="https://files.pythonhosted.org/packages/source/$_pypiprefix/$_pyname/$_pyname-$pkgver.tar.gz"
makedepends="py3-setuptools py3-build py3-installer py3-wheel py3-requests"
checkdepends="py3-pytest"
builddir="$srcdir/$_pyname-$pkgver"
options="!check" # requires network access
build() {
python3 -m build --no-isolation --wheel
}
check() {
python3 -m pytest
}
package() {
python3 -m installer -d"$pkgdir" dist/$_pyname-$pkgver-py2.py3-none-any.whl
}
sha512sums="
dbeb846294928fd608d547b8e4aedf188345ce68ce6e9b4c046e86e5a622d96281cf0507db4d1ba5834c68252bda573da7dac725aa1d7cbeb820c65e166f3a1a stripe-3.2.0.tar.gz
"