# Maintainer: Drew DeVault <sir@cmpwn.com>
_name=stripe
pkgname=py3-stripe
pkgver=2.12.0
pkgrel=0
pkgdesc="An easy whitelist-based HTML-sanitizing tool"
url="https://github.com/stripe/stripe-python"
arch="noarch"
license="MIT"
depends="python3"
makedepends="py-setuptools py3-requests"
source="https://pypi.org/packages/source/s/stripe/stripe-$pkgver.tar.gz"
builddir="$srcdir/${_name}-${pkgver}"
check() {
cd "$builddir"
python3 setup.py check
}
package() {
cd "$builddir"
python3 setup.py install --root="$pkgdir" --optimize=1
}
sha512sums="524ad0cb2b474137d13d5b92e13af820b8979e8c020a2d097f59371e0d8087b7ddd5cd9d8655329f2094c2f5064997973780f720049562891ca831f164976484 stripe-2.12.0.tar.gz"