# Maintainer: Drew DeVault <sir@cmpwn.com>
pkgname=py3-stripe
_pyname=stripe
pkgver=2.73.0
pkgrel=0
pkgdesc="Python library for the Stripe API"
url="https://github.com/stripe/stripe-python"
arch="noarch"
license="MIT"
depends="python3"
_pypiprefix="${_pyname%${_pyname#?}}"
source="https://files.pythonhosted.org/packages/source/$_pypiprefix/$_pyname/$_pyname-$pkgver.tar.gz"
makedepends="py3-setuptools py3-requests"
builddir="$srcdir/$_pyname-$pkgver"
build() {
python3 setup.py build
}
check() {
python3 setup.py check
}
package() {
python3 setup.py install --root="$pkgdir" --optimize=1
}
sha512sums="
e2b41d28c9a63564a86e2acd1f36727b34f9133b43104ad6736ad9f706396ce534e59252728342ffea1ce766fcc15b9fc24a00a7797547e8e3fc05943a462a9c stripe-2.73.0.tar.gz
"