# Contributor: Drew DeVault <sir@cmpwn.com>
# Maintainer: Drew DeVault <sir@cmpwn.com>
pkgname=py3-pyphen
_pyname=pyphen
pkgver=0.11.0
pkgrel=1
pkgdesc="python-based dictionary hyphenator library"
url="https://www.pyphen.org"
arch="noarch"
license="GPL-2.0-or-later AND LGPL-2.1-or-later AND MPL-1.1"
depends="python3"
makedepends="py3-setuptools"
_pypiprefix="${_pyname%${_pyname#?}}"
source="https://files.pythonhosted.org/packages/source/$_pypiprefix/$_pyname/$_pyname-$pkgver.tar.gz"
builddir="$srcdir"/$_pyname-$pkgver
options="!check" # upsteram provides no tests
build() {
python3 setup.py build
}
package() {
python3 setup.py install --prefix=/usr --root="$pkgdir"
}
sha512sums="
49f510cdc00af479054c64380de8fb5722e2c99a3cf0f882c4b78b82c80300b6cb28c53c593a091e358eae662b28a50ac6e63afb8d57f2adf5c03e5a7f879c68 pyphen-0.11.0.tar.gz
"