# Contributor: Drew DeVault <sir@cmpwn.com>
# Maintainer: Drew DeVault <sir@cmpwn.com>
pkgname=py3-aiosmtpd
_pyname=aiosmtpd
pkgver=1.2.2
pkgrel=1
pkgdesc="A reimplementation of the Python stdlib smtpd.py based on asyncio"
url="https://github.com/aio-libs/aiosmtpd"
arch="noarch"
license="Apache-2.0"
depends="py3-atpublic"
makedepends="python3-dev py3-setuptools py3-pytest"
_pypiprefix="${_pyname%${_pyname#?}}"
source="
https://files.pythonhosted.org/packages/source/$_pypiprefix/$_pyname/$_pyname-$pkgver.tar.gz
0001-Make-LHLO-behave-like-EHLO.patch
"
replaces="py-aiosmtpd"
builddir="$srcdir"/$_pyname-$pkgver
build() {
python3 setup.py build
}
check() {
pytest-3
}
package() {
python3 setup.py install --prefix=/usr --root="$pkgdir"
}
sha512sums="7ffc279a73685601496dbfffef30a78cc254a76f8c8fccd0c7b7efe41da66672f0d8662f302eb928e90eb8977b859cb7e713415d0aa5e93f369ef23bdff405fc aiosmtpd-1.2.2.tar.gz
fac4ce50a992d3d77a57b8da2cf9656f0c3945a446b31121269d7f04290d1e656ee21d9bd044830e1447cc11ddc160baf59ef034e279e12deed1bc25f916a832 0001-Make-LHLO-behave-like-EHLO.patch"