# Maintainer: Drew DeVault <sir@cmpwn.com>
pkgname=py3-editor
_pyname=python-editor
pkgver=1.0.4
pkgrel=2
pkgdesc="Programmatically open an editor, capture the result"
url="https://github.com/fmoo/python-editor"
arch="noarch"
license="Apache"
makedepends="python3-dev py3-setuptools py3-six"
_pypiprefix="${_pyname%${_pyname#?}}"
source="https://files.pythonhosted.org/packages/source/$_pypiprefix/$_pyname/$_pyname-$pkgver.tar.gz"
replaces="py-editor"
builddir="$srcdir/${_pyname}-${pkgver}"
# This package is very simple and has no tests
options="$options !check"
build() {
python3 setup.py build
}
package() {
python3 setup.py install --prefix=/usr --root="$pkgdir"
}
sha512sums="c8ce2403bfe6c93935c7f4c384a8618a39cdaefe1ff5b1ff2cf4562866d8b3caa616e428c0a1634a56db934caeb474e7f84f8d5e009b9ed664189fdece8146f6 python-editor-1.0.4.tar.gz"