# Contributor: Stefan Wagner <stw@bit-strickerei.de>
# Maintainer: Drew DeVault <sir@cmpwn.com>
pkgname=py3-pyphen
_pyname=Pyphen
pkgver=0.10.0
pkgrel=0
pkgdesc="python-based dictionary hyphenator library"
url="https://www.pyphen.org"
arch="noarch"
license="GPL-2.0-or-later AND LGPL-2.1-or-later AND MPL-1.1"
depends="python3"
makedepends="py3-setuptools"
checkdepends="py3-pytest"
source="$_pyname-$pkgver.tar.gz::https://github.com/Kozea/Pyphen/archive/$pkgver.tar.gz"
builddir="$srcdir/$_pyname-$pkgver"
replaces="py-pyphen" # Backwards compatibility
provides="py-pyphen=$pkgver-r$pkgrel" # Backwards compatibility
options="!check" # upstream provides no tests
build() {
python3 setup.py build
}
package() {
python3 setup.py install --prefix=/usr --root="$pkgdir"
}
sha512sums="b6d789ca6eb010c1c79b28a9a0e68620ea5600adc43111bed5dbda3cb8b3a4c8c05caa3fb44ea60b0ef4a20272f17cf5e6fe61f0d1e48038395407ff53da7a92 Pyphen-0.10.0.tar.gz"