# Maintainer: Drew DeVault <sir@cmpwn.com>
pkgname=py3-stripe
_pyname=stripe
pkgver=2.76.0
pkgrel=0
pkgdesc="Python library for the Stripe API"
url="https://github.com/stripe/stripe-python"
arch="noarch"
license="MIT"
depends="python3"
_pypiprefix="${_pyname%${_pyname#?}}"
source="https://files.pythonhosted.org/packages/source/$_pypiprefix/$_pyname/$_pyname-$pkgver.tar.gz"
makedepends="py3-setuptools py3-build py3-installer py3-wheel py3-requests"
checkdepends="py3-pytest"
builddir="$srcdir/$_pyname-$pkgver"
options="!check" # requires network access
build() {
python3 -m build --no-isolation --wheel
}
check() {
python3 -m pytest
}
package() {
python3 -m installer -d"$pkgdir" dist/$_pyname-$pkgver-py2.py3-none-any.whl
}
sha512sums="
e416043dff74791d3f06809ed611ea1e250b9dae9404092915a674c6fe65eba546eb020cfdb7635fde8d0626e2c1fa4176cec7362870fc02bee619216b58cec2 stripe-2.76.0.tar.gz
"