# Contributor: Leo <thinkabit.ukim@gmail.com>
# Maintainer: Leo <thinkabit.ukim@gmail.com>
pkgname=py3-gitlab
_pkgname=python-gitlab
pkgver=3.3.0
pkgrel=0
pkgdesc="v4 GitLab API compliant library and cmdline tool"
options="!check" # Requires unpackaged 'httmock'
url="https://github.com/python-gitlab/python-gitlab"
arch="noarch"
license="LGPL-3.0-or-later"
depends="python3 py3-requests py3-requests-toolbelt py3-six"
makedepends="py3-setuptools"
checkdepends="py3-pytest py3-mock"
source="https://files.pythonhosted.org/packages/source/p/$_pkgname/$_pkgname-$pkgver.tar.gz"
builddir="$srcdir/$_pkgname-$pkgver"
build() {
python3 setup.py build
}
check() {
py.test-3
}
package() {
python3 setup.py install --prefix=/usr --root="$pkgdir"
}
sha512sums="
4db9efcfa747dc003d9e7a3529d4d6cc42e65e6158efe28e3fc0997b64ed6f2f9add9ba0774cb0b026e3374f2e54ca811f44508e291e064d53ff7a60e28ef460 python-gitlab-3.3.0.tar.gz
"