# Maintainer: Drew DeVault <sir@cmpwn.com>
pkgname=py3-stripe
_pyname=stripe
pkgver=3.3.0
pkgrel=0
pkgdesc="Python library for the Stripe API"
url="https://github.com/stripe/stripe-python"
arch="noarch"
license="MIT"
depends="python3"
_pypiprefix="${_pyname%${_pyname#?}}"
source="https://files.pythonhosted.org/packages/source/$_pypiprefix/$_pyname/$_pyname-$pkgver.tar.gz"
makedepends="py3-setuptools py3-build py3-installer py3-wheel py3-requests"
checkdepends="py3-pytest"
builddir="$srcdir/$_pyname-$pkgver"
options="!check" # requires network access
build() {
python3 -m build --no-isolation --wheel
}
check() {
python3 -m pytest
}
package() {
python3 -m installer -d"$pkgdir" dist/$_pyname-$pkgver-py2.py3-none-any.whl
}
sha512sums="
4f00fd9901a5b4d873c4a9a00483f57f4cd9359f8a440b3d783e7aeed250e33400a7405ca8ea5af29fd1b44bc84c65fa59c8121e4ffb4852584ffd3fc2099910 stripe-3.3.0.tar.gz
"