# Maintainer: Drew DeVault <sir@cmpwn.com>
pkgname=py3-weasyprint
_pyname=weasyprint
pkgver=54.2
pkgrel=0
pkgdesc="cairo-based HTML renderer for python"
url="https://weasyprint.org"
arch="noarch"
license="BSD-3-Clause"
depends="
pango cairo py3-cairocffi py3-cairosvg py3-cssselect2 py3-tinycss2
py3-pyphen py3-lxml py3-pdfrw py3-fonttools py3-pydyf py3-html5lib
py3-pillow
"
makedepends="py3-setuptools pyproject2setuppy"
checkdepends="
py3-pytest
py3-pytest-cov
py3-pytest-isort
py3-pytest-flake8
py3-pytest-runner
ghostscript
"
_pypiprefix="${_pyname%${_pyname#?}}"
source="https://files.pythonhosted.org/packages/source/$_pypiprefix/$_pyname/$_pyname-$pkgver.tar.gz"
builddir="$srcdir"/$_pyname-$pkgver
options="!check" # shit's broke
prepare() {
# Here's a cool idea: let's add a style linter to our test suite, then ship
# releases with style errors so that our release tarballs have failing
# tests! Brilliant!
sed -i pyproject.toml -e 's/--isort//'
for mod in formatting_structure text
do
touch weasyprint/$mod/__init__.py
done
}
build() {
python3 -m pyproject2setuppy.main build
}
check() {
python3 -m pytest
}
package() {
python3 -m pyproject2setuppy.main install --prefix=/usr --root="$pkgdir"
}
sha512sums="
fd7d07085f104958872a7ccf82d3ffc748936a4fd2d7757847b54de5248e1517a5f244b406cb052c809daa8194d0fa0701e05703b66afe8a809eff70d2cde8f3 weasyprint-54.2.tar.gz
"