# Maintainer: Drew DeVault <sir@cmpwn.com>
pkgname=py3-emailthreads
pkgver=0.1.0
pkgrel=0
pkgdesc="Python library to parse and format email threads"
url="https://github.com/emersion/python-emailthreads"
arch="noarch"
license="MIT"
depends="python3"
makedepends="py-setuptools"
source="
$pkgname-$pkgver.tar.gz::https://github.com/emersion/python-emailthreads/archive/v$pkgver.tar.gz
0001-Don-t-strip-whitespace-from-lines.patch
0002-Ignore-UTF-8-errors-when-decoding-emails.patch
"
builddir="$srcdir/python-emailthreads-${pkgver}"
options="!check" # no upstream test suite
build() {
cd "$builddir"
python3 setup.py build
}
package() {
cd "$builddir"
python3 setup.py install --root="$pkgdir" --optimize=1
}
sha512sums="42e7fb8dfbfcbe514c44324816eca4fbb859410e3548458f32a18560dd52514a9236d860a8397d76eb992c30a0807c93aff896e95296f1f932d3693e975124e7 py3-emailthreads-0.1.0.tar.gz
467fda3c10394742d5a709addd2c24ff8eb27c294f912e651f1cf04e58802a501126d984b4d01323904aea4e216dd747cc681960c2157d04b6e21b0199c26bb2 0001-Don-t-strip-whitespace-from-lines.patch
e023086d3974cbff2b848deeaab00d26d27a4f2b060b5b53350af9e23a20d1055d78dccd35ec06fc4ee039ca8e0d861b8084b8c1bbb95a776f652b4611cac0f7 0002-Ignore-UTF-8-errors-when-decoding-emails.patch"