# Contributor: Ludovic Chabant <ludovic@chabant.com>
# Maintainer: Ludovic Chabant <ludovic@chabant.com>
pkgname=hg-evolve
pkgver=9.2.1
pkgrel=2
pkgdesc="Flexible evolution of Mercurial history."
url="https://www.mercurial-scm.org/repo/evolve"
arch="all"
license="GPLv2+"
depends="mercurial"
makedepends="python3-dev py-setuptools"
source="$pkgname-$pkgver.tar.gz::https://files.pythonhosted.org/packages/18/6c/7ae28f077dc8c9f522570e5be8a86a961bfdd47387afa1a708df034a5353/hg-evolve-9.2.1.tar.gz"
builddir="${srcdir}/${pkgname}-${pkgver}"
prepare() {
default_prepare
cd "$builddir"
# Removing hgext3rd/__init__.py since it's provided by mercurial
rm hgext3rd/__init__.py
}
build() {
cd "$builddir"
HGPYTHON3=1 python3 setup.py build
}
package() {
cd "$builddir"
HGPYTHON3=1 python3 setup.py install --prefix=/usr --root="$pkgdir"
}
sha512sums="927ba873c583a4027d8c745ba8eb70e8768cd7c4c9a36f773d33d9a77807345cc9d2029c8cbe0d626984a963700399447f2bee01c6a0820a4a46894719f76869 hg-evolve-9.2.1.tar.gz"