# Contributor: Leo <thinkabit.ukim@gmail.com>
# Contributor: Pierre-Gildas MILLON <pgmillon@gmail.com>
# Maintainer: Drew DeVault <sir@cmpwn.com>
pkgname=py3-pygit2
_pkgname=pygit2
pkgver=0.28.2
pkgrel=99
pkgdesc="Python bindings for libgit2"
url="https://github.com/libgit2/pygit2"
arch="all"
license="GPL-2.0 WITH GCC-exception-2.0"
depends="py3-cffi py3-six"
makedepends="python3-dev py3-setuptools libgit2-dev"
checkdepends="py3-pytest py3-hypothesis"
source="https://pypi.io/packages/source/p/$_pkgname/$_pkgname-$pkgver.tar.gz
skip-failing-test-on-s390x.patch
"
builddir="$srcdir/$_pkgname-$pkgver"
replaces="py-pygit" # Backward compat
provides="py-pygit=$pkgver-r$pkgrel" # Backward compat
build() {
python3 setup.py build_ext --inplace
}
check() {
pytest-3
}
package() {
python3 setup.py install --prefix=/usr --root="$pkgdir"
}
sha512sums="3f742cdcc9d603c9cc9ef2e0a545da8bcfb555a0bdeea1c73c53a284b43d40ad6b28c87a029578ad7b1c8f2bf56ecd2859dac8dd836474bfc66223ff4af9e8f0 pygit2-0.28.2.tar.gz
1bd1ed146ebfae659c20aa641f795606a32e485fab13a71db12345082a18a9de9f0129d8375ffb6bf8616c906c59d0b25fb440e1f00bcd56e3e10b9aac3363fd skip-failing-test-on-s390x.patch"