# Maintainer: Drew DeVault <sir@cmpwn.com>
_name=PGPy
pkgname=py3-pgpy
pkgver=0.4.1
pkgrel=1
pkgdesc="Pretty Good Privacy for Python - a pure Python OpenPGP implementation"
url="https://github.com/SecurityInnovation/PGPy"
arch="noarch"
license="BSD"
depends="
py3-cryptography
py3-six
py3-asn1
"
makedepends="py-setuptools"
source="https://github.com/SecurityInnovation/PGPy/releases/download/${pkgver}/PGPy-${pkgver}.tar.gz"
builddir="$srcdir/${_name}-${pkgver}"
check() {
cd "$builddir"
python3 setup.py check
}
package() {
cd "$builddir"
python3 setup.py install --root="$pkgdir" --optimize=1
}
sha512sums="45fbf7c65af7e0b86bd56275ed7af020506774703bbca08adf742cccaf84dbb40c7883fbffe85d2298a4d70013c74ea97c60aa1a1181acd6c0ea6f8067065ec2 PGPy-0.4.1.tar.gz"