# Maintainer: Drew DeVault <sir@cmpwn.com>
_name=redis
pkgname=py3-redis
pkgver=2.10.6
pkgrel=0
pkgdesc="The Python interface to the Redis key-value store"
url="https://github.com/andymccurdy/redis-py"
arch="noarch"
license="MIT"
depends="python3"
makedepends="py-setuptools"
source="$_name-$pkgver.tar.gz::https://github.com/andymccurdy/redis-py/archive/${pkgver}.tar.gz"
builddir="$srcdir/${_name}-py-${pkgver}"
build() {
cd "$builddir"
python3 setup.py build
}
package() {
cd "$builddir"
python3 setup.py install --root="$pkgdir" --optimize=1
}
sha512sums="b3a674ec248add9d6fd537c2d98bda48fc1867d111015dee772812e04e92dab879a2f913fb5d366ea3bb8469da6f1c91bdb3d73e797405d14a52109ff125a122 redis-2.10.6.tar.gz"