# Maintainer: Drew DeVault <sir@cmpwn.com>
pkgname=py3-stripe
_pyname=stripe
pkgver=2.71.0
pkgrel=0
pkgdesc="Python library for the Stripe API"
url="https://github.com/stripe/stripe-python"
arch="noarch"
license="MIT"
depends="python3"
_pypiprefix="${_pyname%${_pyname#?}}"
source="https://files.pythonhosted.org/packages/source/$_pypiprefix/$_pyname/$_pyname-$pkgver.tar.gz"
makedepends="py3-setuptools py3-requests"
builddir="$srcdir/$_pyname-$pkgver"
build() {
python3 setup.py build
}
check() {
python3 setup.py check
}
package() {
python3 setup.py install --root="$pkgdir" --optimize=1
}
sha512sums="
5acbaba1e2a5e063beafd0b67994a4a4c7d207f220a49e84b7ab3c0288a92150fd10048f7782e32c3033f4a920f5e81a0893610545e5d1f49ee6dbe62aa4b3a5 stripe-2.71.0.tar.gz
"