# Maintainer: Drew DeVault <sir@cmpwn.com>
pkgname=py3-iso3166
_pyname=iso3166
pkgver=1.0.1
pkgrel=4
pkgdesc="Self-contained ISO 3166-1 country definitions for Python"
url="https://github.com/deactivated/python-iso3166"
arch="noarch"
license="MIT"
depends="python3"
makedepends="py3-setuptools"
checkdepends="py3-pytest"
_pypiprefix="${_pyname%${_pyname#?}}"
source="https://files.pythonhosted.org/packages/source/$_pypiprefix/$_pyname/$_pyname-$pkgver.tar.gz"
builddir="$srcdir/$_pyname-$pkgver"
build() {
python3 setup.py build
}
check() {
PYTHONPATH=. pytest-3
}
package() {
python3 setup.py install --root="$pkgdir" --optimize=1
}
sha512sums="44da1b987f01494fc7874b044fa6b0ed8a888bd159f73ab239f9db35e26c4fd310444164e538166c3804d796c0ab212bb1b1eee02eb3b9b70883d5d2d7ccccc0 iso3166-1.0.1.tar.gz"