# Maintainer: Drew DeVault <sir@cmpwn.com>
_name=html5lib
pkgname=py3-html5lib
pkgver=0.999999999
pkgrel=0
pkgdesc="A Python HTML parser/tokenizer based on the WHATWG HTML5 spec"
url="https://github.com/html5lib"
arch="noarch"
license="MIT"
depends="python3 py3-six py3-webencodings"
makedepends="py-setuptools"
source="${pkgname}-${pkgver}.tar.gz::https://github.com/html5lib/html5lib-python/archive/${pkgver}.tar.gz"
builddir="$srcdir/html5lib-python-${pkgver}"
check() {
cd "$builddir"
python3 setup.py check
}
package() {
cd "$builddir"
python3 setup.py install --root="$pkgdir" --optimize=1
}
sha512sums="74205c25ea38a1a0690181d56bdf4560ef36cf0d39acbb1ab16e2199e3657f87636508ba128d522970876c9a0ba2ac8df877053ff0179403668a2f0300af7877 py3-html5lib-0.999999999.tar.gz"