# Maintainer: Drew DeVault <sir@cmpwn.com>
pkgname=py3-deprecated
_pyname=Deprecated
pkgver=1.2.5
pkgrel=0
pkgdesc="Python @deprecated decorator to deprecate old python classes, functions or methods"
url="https://github.com/tantale/deprecated"
arch="noarch"
license="MIT"
depends="python3 py3-wrapt"
_pypiprefix="${_pyname%${_pyname#?}}"
source="https://files.pythonhosted.org/packages/source/$_pypiprefix/$_pyname/$_pyname-$pkgver.tar.gz"
builddir="$srcdir/$_pyname-$pkgver"
build() {
python3 setup.py build
}
check() {
python3 setup.py test
}
package() {
python3 setup.py install --prefix=/usr --root="$pkgdir"
}
sha512sums="c8dfbfe46099029e789a4fc3b40b00ee1d34ce184b3a272e5d34a43c67e7ac966d73c366d047e39f40ffa8825803a43acb3f3d2db7b1f34dbf8bf9115a4a6889 Deprecated-1.2.5.tar.gz"