# Maintainer: Drew DeVault <sir@cmpwn.com>
pkgname=py3-orderedmultidict
_pyname=orderedmultidict
pkgver=1.0
pkgrel=0
pkgdesc="Ordered multivalue dictionary that retains method parity with dict."
url="https://github.com/gruns/orderedmultidict"
arch="noarch"
license="Unlicense"
depends="python3 py3-six"
makedepends="py3-setuptools"
_pypiprefix="${_pyname%${_pyname#?}}"
source="https://files.pythonhosted.org/packages/source/$_pypiprefix/$_pyname/$_pyname-$pkgver.tar.gz"
builddir="$srcdir/$_pyname-$pkgver"
build() {
python3 setup.py build
}
check() {
python3 setup.py check
}
package() {
python3 setup.py install --root="$pkgdir" --optimize=1
}
sha512sums="7f731bde1f9cdd3e0490d3f590f2bfefa21935155d309d7460e45e11a640272de15a192200cb5110cf45876b7d6f0b6c7eac635fd122f6225b25aca90a4d6d36 orderedmultidict-1.0.tar.gz"